/ Mikrotik / Multi ESSID Configuration + Vlan with Mikrotik Routerboard and Ubiquiti Unifi

Multi ESSID Configuration + Vlan with Mikrotik Routerboard and Ubiquiti Unifi

MikrotikVlanVisio-700x325
jason on 16 luglio 2014 - 9:00 in Mikrotik, Other, Senza categoria, Wireless

Today i’ll show you a little bit complicated configration that i did few days ago.

In this example i’ll show you how to configure three interface under your custom subnet and your dhcp server by using an Ubiquiti Unifi Antenna and a Mikrotik RouterBoard 1000.

We’ve two physical interface and two Vlan: the phy interface are ether3 and ether4 and the vlan are 10 and 20.

Ether4 port will be configurated as trunk for the Unifi and it will transport the 2 vlan otherwise ether3 will be configurated with the management network and untagged to reach the pc where the Ubiquiti Unifi controller is.

 

PHASE 1: Mikrotik Configuration

/interface bridge
add l2mtu=1598 name=lan
add l2mtu=1594 name=vlan10
add l2mtu=1594 name=vlan20
 
/interface vlan
add interface=ether4 l2mtu=1594 name=vl-lan10-ether4 vlan-id=10
add interface=ether4 l2mtu=1594 name=vl-lan20-ether4 vlan-id=20
 
/ip dns
set allow-remote-requests=yes servers=8.8.4.4,208.67.220.220
/ip dns static
add address=192.168.9.100 name=unifi
 
/interface bridge port
add bridge=lan interface=ether3
add bridge=lan interface=ether4
add bridge=vlan10 interface=vl-lan10-ether4
add bridge=vlan20 interface=vl-lan20-ether4
 
/ip neighbor discovery
set vl-lan10-ether4 discover=no
set vl-lan20-ether4 discover=no
 
/ip pool
add name=dhcp_lan ranges=192.168.9.2-192.168.9.254
add name=dhcp_vlan10 ranges=192.168.10.2-192.168.10.254
add name=dhcp_vlan20 ranges=192.168.20.2-192.168.20.254
 
/ip dhcp-server
add address-pool=dhcp_lan disabled=no interface=lan name=dhcp_lan
add address-pool=dhcp_vlan10 disabled=no interface=vlan10 name=dhcp_vlan10
add address-pool=dhcp_vlan20 disabled=no interface=vlan20 name=dhcp_vlan20
 
/ip address
add address=192.168.9.1/24 interface=lan network=192.168.9.0
add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
 
/ip dhcp-server network
add address=192.168.9.0/24 dhcp-option=unifi dns-server=192.168.9.1 gateway=\
192.168.9.1
add address=192.168.10.0/24 dhcp-option=unifi dns-server=192.168.10.1 gateway=\
192.168.10.1
add address=192.168.20.0/24 dhcp-option=unifi dns-server=192.168.20.1 gateway=\
192.168.20.1

PHASE 2: Unifi Configuration

 

Now we can connect to the pc where the Ubiquiti software is on the ether3 port.

Set our ip address as 192.168.9.100/24 with 192.168.9.1 as gateway.

Open the browser to https://localhost:8443 and we can execute the Wizard for the first configuration. The we can go to Settings -> Wlan Group and we add the ESSID WIFI-MGM without Vlan so it will be only on 192.168.9.0/24 netwrok.

Then we will add 2 new ESSID, ex. WIFI-VLAN10 and WIFI-VLAN20 under the same vlan with their networks: 192.168.10.0/24 and 192.168.20.0/24

Now we can do whatever we want to our different Wifi, for example limit the Bandwidth under the WIFI-VLAN10 or make one Wifi as an Hotspot.

Free your mind!

Hope it will be useful!

0 POST COMMENT
Rate this article

Send Us A Message Here

L'indirizzo email non verrà pubblicato. I campi obbligatori sono contrassegnati *

È possibile utilizzare questi tag ed attributi XHTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>